← Back to CVE List
Vulnerability Intelligence Report
jQuery has a potential XSS vulnerability

CVE-2020-11022

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Cross-Site Scripting (XSS) No Active Exploit Signals
CVSS Base Score
6.9
MEDIUM
Exploitability:1.7
Impact Score:4.8
EPSS Probability:99.22%
Executive Threat Verdict
Evaluating...
Evaluating Threat Landscape...
Assessing known weaponization, exploitation telemetry, and federal advisories.
Attack Surface
—
Authentication
—
Weaponization
—
SSVC Action
—

Weaknesses (CWE)

CWE-79 ↗CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products & Versions

Vendor Product Affected Versions
jquery jQuery >= 1.12.0, < 3.5.0 (affected)

References & Technical Advisories

No reference links found.

Threat Intelligence Signals

EPSS Score
99.215%
Vulnerability Class
Cross-Site Scripting (XSS)

Identity & Timeline

StatusPUBLISHED
Assigning AuthorityGitHub, Inc. · Vendor · USA
Reserved2020-03-30T00:00:00
Published2020-04-29T00:00:00
Last Updated2026-11-02T17:54:18

LINK COPIED TO CLIPBOARD