Vulnerability Intelligence Report
XSS in Dart
CVE-2020-8923
An improper HTML sanitization in Dart versions up to and including 2.7.1 and dev versions 2.8.0-dev.16.0, allows an attacker leveraging DOM Clobbering techniques to skip the sanitization and inject custom html/javascript (XSS). Mitigation: update your Dart SDK to 2.7.2, and 2.8.0-dev.17.0 for the dev version. If you cannot update, we recommend you review the way you use the affected APIs, and pay special attention to cases where user-provided data is used to populate DOM nodes. Consider using Element.innerText or Node.text to populate DOM elements.
No Active Exploit Signals
CVSS Base Score
5.4
MEDIUM
Exploitability:2.9
Impact Score:2.6
EPSS Probability:0.32%
Executive Threat Verdict
Evaluating...
Evaluating Threat Landscape...
Assessing known weaponization, exploitation telemetry, and federal advisories.
Attack Surface
—
Authentication
—
Weaponization
—
SSVC Action
—
Weaknesses (CWE)
CWE-79 ↗CWE-79 Cross-site Scripting (XSS)
Affected Products & Versions
| Vendor | Product | Affected Versions |
|---|---|---|
| Dart SDK | stable <= 2.7.1 (affected), dev <= 2.8.0-dev.16.0 (affected) |
References & Technical Advisories
No reference links found.
Threat Intelligence Signals
EPSS Score
0.316%
Identity & Timeline
| Status | PUBLISHED |
| Assigning Authority | Google LLC · Vendor · USA |
| Reserved | 2020-02-12T00:00:00 |
| Published | 2020-03-26T11:31:55 |
| Last Updated | 2024-08-04T10:12:10 |
Community Chatter & Buzz