Vulnerability Intelligence Report
Buffer overflow in Brotli library
CVE-2020-8927
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
No Active Exploit Signals
CVSS Base Score
5.3
MEDIUM
Exploitability:3.9
Impact Score:1.5
EPSS Probability:3.24%
Executive Threat Verdict
Evaluating...
Evaluating Threat Landscape...
Assessing known weaponization, exploitation telemetry, and federal advisories.
Attack Surface
—
Authentication
—
Weaponization
—
SSVC Action
—
Weaknesses (CWE)
CWE-130 ↗CWE-130 Improper Handling of Length Parameter Inconsistency
Affected Products & Versions
| Vendor | Product | Affected Versions |
|---|---|---|
| Google LLC | Brotli | stable <= 1.0.7 (affected) |
References & Technical Advisories
No reference links found.
Threat Intelligence Signals
EPSS Score
3.243%
GitHub Advisory
Identity & Timeline
| Status | PUBLISHED |
| Assigning Authority | Google LLC · Vendor · USA |
| Reserved | 2020-02-12T00:00:00 |
| Published | 2020-09-15T09:15:12 |
| Last Updated | 2026-05-29T20:52:34 |
Community Chatter & Buzz